نحوی اتصال بین سالیدورک و اباکوس

سلام
طریقه کوپل بطور واضح در بسته اموزش داده شده است
و یک مثال هم برای آن ارایه شده
اگر شما بسته را خریداری کردید و بخش مربوطه رو نگاه کرده باشید براحتی متوجه میشید.
بین هر نسخه ای از این دو نرم افزار هم قابل انجام هست

تشکر دکتر جان

1 پسندیده

سلام اقای دکتر
بله بسته رو تهیه کردم. در نرم افزار اباکوس ایکون سالید ایجاد شده. ولی در نرم افزار سالید ورک در قسمت add in گزینه اباکوس ایجاد نمیشه که بخوام تیک بزنم متاسفانه. حتی plug in اباکوس رو دانلود کردم و در پوشه مربوطه سالیدورک کپی هم انجام دادم اما در add in سالید، اباکوس ظاهر نمیشه
چه کار دیگری باید انجام بدم؟؟

1 پسندیده

یکسری فایل پیوست باید همراه هر جلسه موجود باشد،
برای اینکه مشکلتان راحت تر حل بشه شماره خودم رو نوشتم که در واتساپ بهم پیام بدید تا فایل را برایتان براحتی ارسال کنم و توضیحات بیشتر رو همون جا بدم
09134910974

دکتر جان
این فایل کجای بسته گذاشتین تا امتحان کنم؟؟
کدوم شکل پیوست رو باید ببینم؟
اباکوس نسخه 2017
سالیدورک نسخه 2018

سلام اقا محسن عزیز
البته ببخشید فامیلتون خاطرم نیست
خوب شما بعد از اینکه اون فایل dll
رو در پوشه مربوط در سالید کپی کردید باید حتما اون رو از طریق نرم افزار سالید و با انتخاب نوع فایل (dll) بازش (open) کنید
بلافاصله بعد از این کار ایکن مربوط به اباکوس در بخش منوی plug in سالید قابل فعال کردن هست
و بعدش هم طبق فیلم بسته ادامه بدید
باز اگر متوجه نشدید بفرمایید
موفق باشید

سلام مجدد دکتر جان
همون فایل dll رو که در Route سالید کپی کردم طبق اموزش شما باز میکنم پیغام خطا میده
unable to initialize the add-in component
این تو محیط part هستش
وتو محیط assmebly زمانی میخوام فایل open کنم اصلا پسوند dll نداره برای باز کردن
مورد چی میتونه باشه؟

با سلام خدمت استاد محترم،
لطفا نحوی اتصال پویا بین سالید ورک و اباکوس را به صورت واضح توضیح بدین ممنون میشم
مطابق با ویدئو اموزشی مشکل میشه این روش رو انجام داد.
ایا ورژنهای اباکوس و سالید ورک روی این اتصال تاثیر داره؟
تشکر

ببینید توی محیط اسمبلی مطابق شکل پیوست، فایلی که در بسته موجود هست و در پوشه مربوطه کپی کردید رو با نوع dll باز کنید

شکل پیوست رو نگاه کنید
یک سوال سالید شما چه نسخه ای است؟

سلام استاد وقتتون بخیر
موقع Open کردن پلاگین در سالید این اخطار میاد.
Screenshot 2023-08-15 200711

سلام
پلاگینی که در بسته موجود هست برای هر نسخه ای از آباکوس و سالیدورک کار نمی کند،
اگر از نسخه های جدید استفاده می کنید، نیاز هست پلاگین جدید نیز استفاده کنید

1 پسندیده

جناب دکتر سروش با سلام و وقت بخیر.
منظورتون این هست که مثلا با سالید 2024 امکان باز کردن این پلاگین نیست پس راه حل چی هست یعنی باید از ورژن پایین تره سالید برای باز کردن این پلاگین و ادامه آموزش استفاده کنیم یا راه حل دیگه ای هم وجود داره.

سلام و روز بخیر
راه حل دیگری غیر از استفاده از نسخه های پایین تر سالید ورک اینست که از پلاگین های جدید تر مناسب با نسخه های بالاتر اباکوس و سالید ورک استفاده شود.
با جستجوی بیشتر احتمالا بتوان پلاگین های جدیدی تری را پیدا کرد.