مدار سنسور تاریکی

سلام دوست عزیز، به نظر میاد که ترانزیستور شما در حالت اشباع قرار نداره. ترانزیستور ها، می تونن جریان رو کنترل کنن و اینکه چقدر جریان از شاخه امیتر کلکتور عبور می کنه، بسته به مقدار جریانی داره که وارد بیس میشه (یا ازش خارج میشه در pnp)
بنابراین، برای تست این مورد، مقاومت های R2 و LDR1 رو حذف کنید و بیس ترانزیستور رو خیلی ساده با یک مقاومت تحریک کنید و ببینید که آیا رله صدا میده یا نه، در صورتی که صدا داد، ترانزیستور شما در حالت اشباع قرار گرفته (یعنی بیشترین جریان رو عبور میده) و سالم هست.
بعد چک کنید ببینید که چرا با LDR و R2 تحریک انجام نمیشه و باید مقدار R2 رو تغییر بدید.
البته تا جایی که من یادم هست، ما این مدار رو با ترانزیستور pnp بستیم. درسته؟ شما از npn دارید استفاده می کنید.
علاوه بر این، جریان شما از داخل R2 وارد بیس میشه که مقدارش 100K هست و با ولتاژ ۵ ولت، جریان زیادی وارد بیس نمیشه و اینکه شما LED رو روشن میبینید به این علت هست که LED با جریان خیلی کمتر از بوبین رله روشن میشه ولی احتمالا کم نور خواهد بود.

بوبین رله یک سیم پیچ هست که در صورتی که جریان کافی ازش بگذره، باعث تحریک رله و روشن شدن اون میشه. پس میشه گفت که یک تکه سیم هست که یک مقاومتی هم داره.
ولی وقتی که جریان کافی نباشه، رله تحریک نمیشه ولی جریان عبور میکنه ازش. حالت دوم و سوم به این دلیل رخ دادن. در حالتی که موازی با LED بود، الکترون ها ترجیح میدن از مسیر کم مقاومت تر عبور کنن و در نتیجه LED خاموش میشه ولی جریان انقدری نیست که رله رو روشن کنه.
در حالت سوم که سری با LED وصل شده بود، جریانی که از LED میگذره، از سیم پیج رله هم عبور میکنه ولی انقدری نیست که رله تحریک بشه. بنابراین مثل این هست که یک مقاومت نسبتا کوچیک رو با LED سری کردید و فقط یکم نور LED کم میشه و خاموش نمیشه.

سلام دوست عزیز، میشه شماتیک مداری که می بندید رو ارسال کنید؟ آیا بوبین رله شما با ولتاژ مدار همخوانی داره؟ وقتی مدار رو با ال ای دی تست می کنید، ولتاژ دو سر ال ای دی و مقاومتش چقدر هست؟ رله رو مستقیم به منبع تغذیه ای که ازش استفاده می کنید برای این مدار بزنید و ببینید کار میکنه یا نه؟ بعد کلا مدار LDR رو باز کنید و فقط ترانزیستور رو دستی روشن کنید و ببینید رله روشن میشه یا نه. در واقع مرحله مرحله همه حالت ها رو تست کنید و مدار رو از ساده ترین حالت ببندید و برسونید به حالتی که می خواید تا مشکل پیدا بشه.

سلام مجدد خدمت شما
جناب مهندس، شماتیک مدار من به صورت عکس زیر هست که به خوبی عمل میکنه و زمانی که بالای سر LDR تاریک میشه، LED روشن میشه و ولتاژ دو سر اون 1.9 ولت هست. از این قسمت به بعد مدار را در سه حالت آزمایش کردم تا نتایج را ببینم؛
حالت اول: وقتی به جای led و مقاومت یک کیلواهمی، رله قرار میدم، صدای تحریک شنیده نمیشه!
حالت دوم: led و مقاومت یک کیلواهمی را از مدار حذف نکنم و رله را به صورت موازی با این دو المان متصل کنم، led خاموش میشه. با این حساب تصور کردم که شاید در این حالت جریان از بوبین عبور میکنه، ولی همچنان صدای تحریک شنیده نمیشه.
حالت سوم: مورد عجیب تر این هست که وقتی رله را به صورت سری با مقاومت یک کیلواهمی و led میبندم، led روشن میشه ولی همچنان صدای تحریک بوبین شنیده نمیشه. (انگار که رله شبیه سیم عمل میکنه!)
این اتفاقات، خصوصاً حالت سوم، باعث ابهام من در فهم این مدار شده، ممنون میشم راهنمایی بفرمایید.
اطلاعات پیوست:

  • - رله 5 ولت، 7 آمپر هست. و در مدار حالت اول، ولتاژ را تا 12 ولت هم افزایش دادم اما متاسفانه نمیدانم ایراد کار کجاست که صدای تحریک بوبین شنیده نمیشه. وقتی ولتاژ را روی 12 ولت قرار میدم، منبع 0.02 امپر میکشه
  • - در تمامی حالت های بالا وقتی سر مثبت و منفی منبع را مستقیماً به رله وصل میکنم، رله تحریک میشه
  • - یک بار هم ldr را از مدار خارج کردم اما تفاوتی در مدارهای حالت یک تا سه ایجاد نشد
    2021-04-13/1618354479-702466-2021-04-14-02-57-17-window.png
  • عرض سلام و احترام جناب مهندس
    در رابطه با مدار سنسور تاریکی شب، که از رله و ترانزیستور هم استفاده شده بود، ابهامی برای بنده در زمان بستن مدار به وجود آمد. من مدار را با LED و مقاومت تست میکنم و به خوبی نتیجه میدهد. یعنی به محض سایه انداختن بالای LDR، مدار ترانزیستور فعال شده و LED روشن میشه. اما وقتی در همین مدار، LED و مقاومت را با رله جایگزین میکنم، هیچ صدایی مبنی بر تحریک شدن رله شنیده نمیشه. ولتاژ و جریان منبع را هم مقداری افزایش دادم (یک بار ولتاژ را برای لحظاتی تا 9 ولت افزایش دادم و بار دیگر جریان را تا 1 آمپر) اما باز هم صدای تحریک رله شنیده نمیشد. (رله سالم هست و به صورت یک مدار ساده با میکروسوئیچ به خوبی کار می کند). ممنون میشم راهنمایی بفرمایید که مشکل مدار کدام قسمت هست.

    عرض سلام مجدد جناب مهندس، طبق فرموده شما مدار را اصلاح کردم و رله تحریک شد. یعنی در مدار پیشین، ترازیستور در حالت اشباع قرار نمی گرفت. اما حالا سوالی که همچنان در ذهن بنده باقی مانده، نتایجی هست که در مدارهای حالت دوم و سوم (که پیش تر بیان کردم) مشاهده شده! ممنون می شوم علت آن ها را بفرمایید. با سپاس فراوان و همچنین عرض معذرت بابت تاخیر در ادامه این پرسش و پاسخ